Building wheels for a python3/Qt5 project

As I’m a novice in python packaging, I would appreciate some help with packaging a python3 project.
I’ve written down some notes on what I’ve achieved so far in this wiki page.

My current problem is that I need to pip install PyQt5 in order to build my project wheels, but PyQt5 wheels are built using Red Hat 7 and glibc 2.17, while I’m using manylinux2010 (CentOS 6) and glibc 2.12.

Should I try and compile glibc 2.17 in CentOS 6?
Or use CentOS 7 to build the wheels? In that case, the wheels would be accepted as manylinux by PyPI?

Thanks in advance for any suggestion