Change environment variable style

I support using underscores for new variables. In addition to improving readability, it should also improve accessibility, including for people using with screen readers.

As a rough demo, here’s how the VoiceOver screen reader on macOS deals with PYTHONCPUCOUNT and PYTHON_CPU_COUNT:


It really struggles without underscores: PYTHONCPUCOUNT sounds something like “pithon-ki-count”! Whereas PYTHON_CPU_COUNT is much better: “python underscore C P U underscore count”.