Compatible version of Python for Mac OS 10.14.6

I’m running the older OS10.14.6 Mohave on my iMac. What is the latest version of Python that is compatible with this OS?

If I go to the downloads page for the latest version (3.12) (which is linked below the text “Download” on the main Python web site), and scroll to the “Files” section (i.e. actual downloadable installers), I see that this version supports MacOS 10.9 and onward.