Itemgetter `always_tuple` keyword arg

I like unwrap much better.

Ideally, it was named itemsgetter, then it would be clear that it calls __getitem__ many times and stores them in a tuple, while currently it is an object which is meant to do both single and multiple accessing and is named after single. This design makes it fairly difficult to add features to it.

Btw, I don’t like the fact that this requires kwarg either, but as of now I can not see better alternatives. Except one backward-compatibility breaking change:

Having 2 separate itemgetter and itemsgetter would make things more robust and life easier going forward. I even think that making this change now would be worthwhile.

Nothing else will go into that PR.