Make `_PyObject_CallFunctionVa` public

(I’m not sure if I’m allowed to post on the CAPI WG repositories, so I’ll just put my thoughts here)

From the perspective of someone that’s not a core developer, I think the best improvement you guys could make here would be naming consistency. It would be useful if the argument style was denoted through the function name itself – e.g. PyObject_CallVector, PyObject_CallTuple, PyObject_CallVa.

With that being said, I’m personally not a fan of the “object + attribute” style – I try to avoid it when using the C API. (I’m not familiar with the internals of any of those functions, I’m assuming they have some sort of performance benefit, and that’s why people use them.)