No help modules invoking python in terminal

After invoking Python in the terminal, I use to digit ’ help() ’ and then ’ modules '. Basically it runs, but on these last days it won’t print any modules. It raises an error, printing on screen a long series of numpy deprecated stuff, numba debug, llvmlite.llvmpy deprecated…
Finally, there is the following:

This caffe2 python run failed to load cuda module:/usr/lib/python3.10/site-packages/caffe2/python/ undefined symbol: _ZTIN6caffe212OperatorBaseE,and AMD hip module:No module named 'caffe2.python.caffe2_pybind11_state_hip'.Will run in CPU only mode.
Cannot load caffe2.python. Error: /usr/lib/python3.10/site-packages/caffe2/python/ undefined symbol: _ZTIN6caffe212OperatorBaseE

I tried to install caffe2 but…

 × python egg_info did not run successfully.
  │ exit code: 1
  ╰─> [6 lines of output]
      Traceback (most recent call last):
        File "<string>", line 2, in <module>
        File "<pip-setuptools-caller>", line 34, in <module>
        File "/tmp/pip-install-4on5n48i/caffe2_be740238522c428f9d0b4e389e73ea50/", line 108, in <module>
          from tools.setup_helpers.env import check_env_flag, check_negative_env_flag
      ModuleNotFoundError: No module named 'tools'
      [end of output]

Any solution?

You have a bad version of caffe2, likely its not compatible with the version of python3 you are using.

This is the clue that it is caffe2 that is the problem.

Is there a way to check how I installed it? I don’t remember if it was with pip, pip3 or other…

Use python3 -m pip list to see if pip knows the module.
Check you OS package manager to see if it installed it.
If you tell us the OS we can suggest what commands to use.

I’ve almost solved the issue. I discovered that caffe2 is deprecated and now is part of pytorch. I don’t know why numba still works when I search for help() → modules. Anyway, now I can find the documentation about them invoking the command.



Python 3.8.7 (tags/v3.8.7:6503f05, Dec 21 2020, 17:43:54) [MSC v.1928 32 bit (In
tel)] on win32
Type “help”, “copyright”, “credits” or “license” for more information.

python3 -m pip list
File “”, line 1
python3 -m pip list
SyntaxError: invalid syntax


Once again, you need to invoke python3 -m pip ... commands from
your system command prompt (a cmd.exe window), not from an IDE or
the REPL. It’s a windows/DOS command, not a Python statement.


C:>python3 -m pip list
The name ‘python3’ is not recognized as an internal or external command,
executable program or a batch file.




C:>py -m pip list
Package Version

contourpy 1.0.7
cycler 0.11.0
fonttools 4.39.0
importlib-resources 5.12.0
kiwisolver 1.4.4
matplotlib 3.7.1
numpy 1.24.2
packaging 23.0
Pillow 9.4.0
pip 23.0.1
pyparsing 3.0.9
python-dateutil 2.8.2
regex 2022.10.31
setuptools 49.2.1
six 1.16.0
zipp 3.15.0



thank you

matplotlib 3.7.1
numpy 1.24.2

installed but the above modules crash Python 3.8 Windows 7, 32-bit, either directly
or in help>>> …

How to contact developers of
matplotlib 3.7.1
numpy 1.24.2

to know by which version of Python, Windows to be supported

Ok, I am aware , Windows 7 is old
but if Python 3.8 comes with bugs, just remove that version from the public access

I can use Windows 10 PC but jhave to switch monitor, mouse, keyboard

Is Windows 10, 1GB RAM Atom tablet ok, to run Python ?
( have to check if OTG supported to connect external USB hub + usb keyboard, usb mouse)

But tablet is 7", so too small for any daily use

thanks again