Pip install - Error: requires a a different Python: 2.7.17 not in '>=3.8'

Trying to install GitHub - adrn/pyia: a Python package for working with data from the Gaia mission

py --version gives me:
Python 3.12.2

but, pip install git+https://github.com/adrn/pyia gives:
ERROR: Package u’pyia’ requires a different Python: 2.7.17 not in ‘>=3.8’

The version of Python used when you run pip install ... is not necessarily the version of Python that you get from py. To make sure you use that version when you install with Pip, use that version to run Pip: py -m pip install .... (This is probably one of the most frequent issue that comes up here, BTW.)

Thank you! I appreciate it.