Recategorizing a Topic

Users at TL3 are able to recategorize topics, or so it is stated on the Badges / Regular page, as below:


This badge is granted when you reach trust level 3. Thanks for being a regular part of our community over a period of months. You’re now one of the most active readers, and a reliable contributor that makes our community great. You can now recategorize and rename topics, take advantage of more powerful spam flags, access a private lounge area, and you’ll also get lots more likes per day.

However, on May 4, 2022 (yesterday, as this is being written), I tried to perform such a recategorization, with rather unfortunate results. I had noticed a request for help that clearly would have been appropriate for the Users category, but had instead been posted in the Core Workflow category. I clicked the edit icon to the right of the title and used the pulldown menu to change the category to Users, but poof! - the post has effectively disappeared, except for its URL, title, and new classification within Users, which, evidently, the system still remembers. See below:

For convenience, here is the URL, copied from the screen capture:

I have seen this happen before on another Discourse forum.

What can we do at this point to recover the post?

This matter is currently of special concern as we are discussing the possibility of splitting the Users category, which would then require recategorizing some of the existing topics.

I’ve recategorized dozens of topics and seen others do the same, and everything worked relatively seamlessly. I have seen this happen a couple times, both with and without recategorization, but barring a momentary glitch, what I suspect we may be seeing is the user deleting the post (perhaps realizing they are in the wrong category, or having answered the question) right around the same time that we are interacting with it. Or it may be delayed action of the spam filter, moderation action or some other race condition.

For reference, the topic deleted by author issue may be relevant.

1 Like

The post has returned again, intact and recategorized as intended.

Here it is: Code flow question due to unexpected code flow.

From its edit history:


For reference, see this discussion for accounts of similar occurrences on another Discourse forum: Processing Foundation Discourse: Moved thread has disappeared.


Akismet seems to be likely cause of temporary disappearances. See Arduino Forum: Moved topics disappearing?.

Thanks for your feedback Rob,

This is really embarrassing but I think I may have solved it. (or at least got the workflow to function as I had anticipated)

I found that if I destroy the window (only), that the workflow gets buggered up for some reason and returns to its command call from the main Menu on the Main Window, but if I quit the form and then destroy it, that the workflow seems to follow what I was hoping to achieve. (This function is called on the double click (mouse-1) event of the Tkinter → ttk → Treeview.)

I’m not sure why this is … I’m fairly old, set in my ways, tend to program functionally more than OOP(ly), so it may be just that I am stupid. (And have only been doing Python for 3 months now… The languages that I mostly grew up on are now obsolete… C (VC), ASM, Fortran, Cobol, Clipper, Basic, VB, and Turbo Pascal, though I do use (limited) Java script, CSS, HTML for my kids’ school projects and the worst to date … Godot …Argh!. but then I tend not to be a gamer…)




If you have any thoughts as to why this would be, I would be most grateful for your input/thoughts.

Regards and thanks,


We’re glad it worked out well for you. However, in the interest of continuity, your response should be posted as part of the original discussion, which is here: Code flow question due to unexpected code flow. Note that the topic was moved to the Users category, where such material should be posted.

Since this is on topic for both this thread (given the above) and #site-feedback

I know @admins / @moderators can split out individual replies to a new thread, but can they move them to an existing thread (i.e. for those above)?