Setuptools lib error while installing library

Hi ,

I try to install the boxdetect, outlook-msg and docx2txt library. It throws an error as pip subprocess to install build dependencies did not run successfully.
Error: Could not find a version that statisfies the requirement setuptools>=40.8.0

Currently i have setuptools=67.6.0 but still getting the same error and the weird thing this that i am getting same error while installing any lib while have setuptools dependency.

Please let me know how I can resolve this issue.