Unable to install openbabel library anywhere

I’m unable to use the openbabel library in my PyCharm IDE, in powershell, nor in GColab, any tips??

Hello and welcome. In order to be able to help, we need to be able to understand what the actual problem is.

What steps do you take in order to try to “use” this library?

What do you think should happen when you take those steps? What happens instead, and how is that different?

2 Likes

Right right, I have to actually provide info, i’m sorry, Here goes:

I’m on W11, I use PyCharm and currently trying to make a script using the OpenBabel library, I followed the steps from the official website http://openbabel.org/ to install the program, which works perfectly fine, but i get this error when trying to install obabel libraries both in terminal and PyCharm IDE:

Error: SWIG failed. Is Open Babel installed? You may need to manually specify the location of Open Babel include and library directories. For example: python setup.py build_ext -I/usr/local/include/openbabel3 -L/usr/local/lib python setup.py install [end of output]
I´m having trouble manually specifying the location of the obabel’s files
Thank you