Can't Install Python because Executable won't Open

Hello everyone, my name is Luiz and I’m new to this forum, so please forgive me if I’m making some mistake on posting this or anything else.
I wanted to learn programing for a long time and decided to start with Python, but I’m having trouble trying to install it on my computer for at least 3 hours now. The executable file for installation that I download (python-3.11.1-amd64.exe) on simply doesn’t open when I double-click it, it just shows that loading Windows little blue circle and then vanishes.
I’m using Windows 10 Pro Edition, (my Windows Update says it is updated to the latest version), I already tried running it on Admin and Compatibility Modes and already checked if register values for executables are right (and they are), but nothing seems to work.
I also tried Python 2 MSI installer for checking if the problem was occurring on any version of the program, and that one seems to open and work properly, but I don’t want to install Python 2.
If someone can think of any cause or solution to my problem, I would be very thankful.
Thank you all for looking here, have a nice new year! =)

I have exactly that file and it worked fine, as has others for 25 years. Search web for “exe does not open” or similar.

Go to Settings, and then Apps & Features.

At the top, there should be a setting that says:

“Installing apps only from the Microsoft Store helps protect your device.”

What’s that set to? By default, Windows 10 only allows you to install Microsoft Store apps, so it’ll block you from installing from an .exe if you don’t change the setting.

Guys, found my problem here: Python installer was not the only thing failing, there were others that I discovered afterwards. Ran SFC and DISM through CMD and discovered my Windows installation was corrupted, particularly in a way that the Windows Updater itself was not working, so I reinstalled the OS and now everything is back to normal, Python installer included. Thank you all for supporting me, again, have a nice new year!!! =D

It was on “Anywhere” the whole time, I checked that also, but now the problem is solved. Thank you again! =)