Getting requirements to build wheel did not run successfully exit code: 1, for Windows 10

So I had the same error as shown in here.

Anyways, someone showed the solution I believe in Mac or Linux

$ echo "Cython<3" > cython_constraint.txt
$ PIP_CONSTRAINT=cython_constraint.txt pip install "ai-core-sdk[aicore-content]"

Anyways, I asked Google Bard what it does and here’s what it told me.
Here’s a breakdown of what the line PIP_CONSTRAINT=cython_constraint.txt pip install "ai-core-sdk[aicore-content]" does:

1. Environmental Variable:

  • PIP_CONSTRAINT=cython_constraint.txt sets an environment variable named PIP_CONSTRAINT with the value cython_constraint.txt .
  • Environment variables provide configuration values for programs to use.
  • In this case, it’s likely used by pip to specify a file containing version constraints for packages.

2. Package Installation:

  • pip install "ai-core-sdk[aicore-content]" is the main command, instructing pip to install a package named ai-core-sdk with the optional [aicore-content] extra.
  • pip is the package installer for Python, responsible for managing Python packages and their dependencies.
  • The [aicore-content] extra likely indicates additional optional features or components to be included in the installation.

Here’s the Windows 10 equivalent for those who are struggling with that :rofl::sob:.
Windows 10 Equivalent:

  • In both PowerShell and Command Prompt, the syntax is the same:
set PIP_CONSTRAINT=cython_constraint.txt <- Enter
pip install "ai-core-sdk[aicore-content]" <- Enter

The first link that I showed, the topic is closed which is why I felt the need to post this!

I was able to install this but I needed this to install the twodict1.2 but I’m still getting this error.
error: subprocess-exited-with-error

× Getting requirements to build wheel did not run successfully.
│ exit code: 1
╰─> [23 lines of output]
Traceback (most recent call last):

Please include the full error message. “Getting requirements to build wheel did not run successfully.” doesn’t give enough information for us to be able to understand the problem.

1 Like

Try
pip install wheel

I had a similar problem, this worked for me.

5 posts were split to a new topic: Can’t install djoser