Help needed to install Python on MAC OS. I get "The Installation failed" message everytime I install

I am seeking help in installing Python on my Mac.
Whenever I try to install it, I get a message that “The Installation failed.”
Here’s the link to what’s happening on my Mac when I try to install it.

It seems I have given up after trying several blogs and following instructions to manually clean files in the library folder and then using the app cleaner tool and then following StackOverflow steps with no luck.

Basically, I had previously installed Python 3.8 and then uninstalled it in a manner that I do not recall now.

Kindly help or direct me so I can install this as I have enrolled in a 6-month online course that starts in a few days that requires me to have access to Python on my computer.

I use MAC M1 with Ventura OS on it 13.0 (22A380).

Thanks a ton in advance for any help that I can get regarding this.

Put ‘Mac’ in the title so people will not assume that you are on Windows or *nix.

Thanks Terry

I don’t really get why people refer to MacOS as not being a Unix. It’s based on a BSD Unix, and runs many Linux shell scripts well.

Given that the official installer is having problems, maybe try homebrew:

1 Like

Thank you, Daniel.

I did try HomeBrew using the steps described here.

However, at the end of all the steps, when I ran the command “py” it said command not found.

Here are the screenshots and logs from the Terminal window when I installed Homebrew.

Perhaps I was thinking if someone can guide me to do a clean uninstall of python from my MAC.

Maybe try ‘python3’ now as your way of entering the Read Evaluate Print Loop (REPL). Mac and Linuxes tend to get you into the REPL that way. It’s also what you #! to: #!/usr/bin/env python3

1 Like

That worked like a charm Daniel.
Thanks a ton.
Now I was wondering if I can install an IDE like PyCharm and get it to work accordingly.

For Python installation and graphics - tkinter - tcl/tk issues (and some others), macOS is quit different from standard *nixes with pre-installed python and installation managers and x-window tcl/tk. And this is an install question. Where macOS does act like *nix is starting 3.x with ‘python3’ or ‘python3.x’ in the bash terminal command line.

Give it a try. :slight_smile: Last I heard, there was a free edition and a professional edition to choose between.

Yes. I installed and it is working fine.
Really appreciate your prompt response.

Hi - I think this error is common. It can be maddening to figure out why the default installation fails and there is surprisingly little discussion of it online.

Yes, you can do the installation through ‘terminal’ using Homebrew or other command line initiated installs, but I don’t think you’ll get the python IDLE app installed - which is nice to have and use (at least when you’re starting out in Python).

I’ve encountered the same problem when installing to Catalina, Monterey and Ventura … and applied the same fix. It’s no guarantee it’s what you’re problem is, but here’s what I did to rectify:

From System Settings => Privacy & Security => Full Disk Access => Toggle the “Installer” App to ON

… then retry the install - hopefully successfully.

1 Like

Hi V R
Thanks for the tip.
I am trying your cue but I am not sure what should I toggle “On”.
See the screenshot below:

1 Like

Thx a lot !!

This solved the problem immediately.
Maddening indeed - is it so hart to give this info either at download time or in a readme ?

For those who don’t find the Installer App - it’s in System>Library>Core Services



thanks for this. I am a noob at this and I have to say this is … beyond exasperating that following the standard instructions literally does not work at all. I tried your suggestion and gave installer full file access – unfortunately still doesn’t work. I can get the environment to open by using
python3 -m idlelib at the command line.

I guess for the time being I’ll just open a terminal window each time and go with the command line. Again, astonishing to me that nobody at Apple or at Python has rolled out a fix for this.

you’re literally a lifesaver, I appreciate your advice this worked right away thank you!!!

If you are using any kind of cloud service file sync like OneDrive (I use OneDrive) or perhaps even iCloud, copy the installer pkg to your desktop and try again. This fixed the installer issue for me. Hope this helps somebody!

The “The installation failed” issue should also be fixed in macOS 13.4 by a change in the OS.

Not fixed in MacOS 13.5 (attempting to install python 3.11.4 using Mac installer for 64-bit Apple M1).

What error do you get?

When I reinstall 3.11.4 on an M1 system running 13.5 I get a popup about accessing the Downloads folder and installation proceeds without errors when I consent to that. This happens every time, the consent isn’t stored (as expected given the changes in 13.4).