IDLE editing window no longer works

IDLE editing window no longer works

after installation of Python 3.9 on Windows 10, IDLE worked fine

As PIP was not recognized and I could not install Matplotlib
I installed PIP with
"C:\Users\xxx>py -m pip install SomePackage "
(note that the command " C:\Users\xxx>python -m pip install SomePackage " does not work )

Everything worked normally afterwards, and IDLE too.

But the next day after rebooting the computer, I don’t have the command “open with IDLE” anymore, the edit window doesn’t appear, only the console appears.

I reinstalled Python and the problem remains (Matplotlib is still present)

None of the possible causes listed in “IDLE — Python 3.9.1 documentation” are affected or correct the problem

here also the command “python -m idlelib” in the console, does not work and returns “python is not found” but the command “py -m idlelib” works fine

Thank you for your help

Translated with (free version)

When you say, ‘no longer works,’ what exactly do you mean? The window doesn’t open? It opens, but you can’t do anything with it?

Hi …Thank you
n fact, when I made a right click on my file
file, I couldn’t see the mention “open with IDLE”.
But 2 days ago someone on another forum told me that you have to check the “path” box when you install Python and now it works correctly.
I have to put my post in “resolute”.
thank you all the same