IDLE won't open

Hi. I’m new to python, but my understanding is that it comes with an IDE prepackaged, Python IDLE. However, when I try to open it, nothing happens; the console doesn’t even open. Any idea what could be going on? I already tried uninstalling and reinstalling and restarting my computer. Thanks in advance for any help.


Hey Matt and welcome.

You should be able to run idle from your CLI, by entering its name.

So, what does your CLI return when you try that?

Also, what OS are you running?

When I try entering idle into the Windows 10 command prompt, it still doesn’t open. This is what I get. Am I setting the WD wrong?


I’m not a MS Windows user.

Maybe this thread will help you.

Thanks, Rob. Do you use the built-in IDLE or do you prefer working within a different IDLE? I’m an R user and like the R Studio IDLE a lot. I’m wondering if there is something similar for python.

In any event, I think it might be a good idea to at least try out the built-in IDLE before I decide to transition to something else. I’ll see what I can figure out.

You’re welcome Matt; sorry I could not be of more help.

Tbh, although I admire the work that must have gone into building idle (it was build with Tkinter, so far as I can tell, but I could be wrong, so don’t quote me on that point), I don’t use it. Not everyone uses an IDE, and those that do have their own preference; mine is Wing Personal. I’m still using v8.2.0.2, but I know that v9.x.x is out. I’ll get around to updating, at some point.

1 Like

Thanks. Does it make more sense for a beginner to download 101 instead or Personal?

I can’t say, as I’ve not used 101; sorry – I simply went with Personal. Maybe give then both a try; you’ve nothing to lose, time aside.

To add: if you’ve any experience with programming, in whatever language (I’ve used C and BASIC) then go with Personal, as you’ll find the tools to be very familiar.

If you installed with launcher from and you installed the py launcher, which one should,

py -m idlelib

If you added python to path (not recommended)

python -m idlelib

Or on Start menu scroll down to Python 3.x and click IDLE entry. I pin the taskbar icon and use there thereafter.

After doing this, do you see any process with that name in the Task Manager? Maybe the windows are just off-screen or minimized for some reason.

I did. I didn’t know this wasn’t recommended! I’ll look into the py launcher. Where should I download it?

After running python -m idlelib, I get this result. It looks like there’s a problem with the Tcl installation; perhaps I’m using the wrong version?

C:\Users\madou>python -m idlelib
Traceback (most recent call last):
  File "<frozen runpy>", line 198, in _run_module_as_main
  File "<frozen runpy>", line 88, in _run_code
  File "C:\Program Files\Python311\Lib\idlelib\", line 6, in <module>
    import idlelib.pyshell
  File "C:\Program Files\Python311\Lib\idlelib\", line 51, in <module>
    from import idle_formatwarning, StdInputFile, StdOutputFile
  File "C:\Program Files\Python311\Lib\idlelib\", line 94, in <module>
    tcl = tkinter.Tcl()
  File "C:\Program Files\Python311\Lib\tkinter\", line 2428, in Tcl
    return Tk(screenName, baseName, className, useTk)
  File "C:\Program Files\Python311\Lib\tkinter\", line 2326, in __init__ = _tkinter.create(screenName, baseName, className, interactive, wantobjects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following directories:
    {C:\Users\madou\AppData\Local\apps\Tcl86\lib\tcl8.6} {C:/Program Files/Python311/lib/tcl8.6} {C:/Program Files/lib/tcl8.6} C:/lib/tcl8.6 {C:/Program Files/library} C:/library C:/tcl8.6.12/library C:/tcl8.6.12/library

C:/Users/madou/AppData/Local/apps/Tcl86/lib/tcl8.6/init.tcl: version conflict for package "Tcl": have 8.6.12, need exactly 8.6.10
version conflict for package "Tcl": have 8.6.12, need exactly 8.6.10
    while executing
"package require -exact Tcl 8.6.10"
    (file "C:/Users/madou/AppData/Local/apps/Tcl86/lib/tcl8.6/init.tcl" line 19)
    invoked from within
"source C:/Users/madou/AppData/Local/apps/Tcl86/lib/tcl8.6/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"

This probably means that Tcl wasn't installed properly.

Nope. Still nothing…

Whenever you install Python on Windows, there should be an option in the installer to provide it. Full documentation is here.

What does where idle report?

The tcl version mismatch is the problem. IDLE cannot run until import tkinter works.

How did you install python? installer, windows store, something else, more than one? Did you ever install tcl directly? Based on my 3.11 installation, the py org installer should have installed …/Python311/tcl/* 8.6.12 version, along with Lib/tkinter/* and other stuff.

The py launcher is an option, on by default, in the py org installer. If you have that, rerunning to repair will install. And possibly fix the tcl problem.

Sorry, I didn’t realize that I had replies.

I was able to figure out that the problem was that init.tcl and tk.tcl had this line of code

package require -exact Tcl 8.6.10

Since I had 8.6.12 installed, it wouldn’t let me open IDLE. Thankfully, all I had to do was change 10 to 12 and problem solved.

PS, it appears that I do have py launcher, but I’m also installed on PATH. Is that an issue? Should I be launching with py instead of python?

And where idle returns INFO: Could not find files for the given pattern(s).

Glad you solved it. Python on PATH only becomes an issue when you uninstall or install another version. Do as you want for the present.