ImportError: urllib3 v2.0 only supports OpenSSL 1.1.1+

"urllib3 v2.0 only supports OpenSSL 1.1.1+, currently "

ImportError: urllib3 v2.0 only supports OpenSSL 1.1.1+, currently the ‘ssl’ module is compiled with ‘OpenSSL 1.1.0j 20 Nov 2018’. See: Drop support for OpenSSL<1.1.1 · Issue #2168 · urllib3/urllib3 · GitHub

OpenSSL 1.1 has passed its end-of-life and has known security bugs.

Ask urllib3 maintainers to support OpenSSL 3.0+ so that you have a supported version of OpenSSL. Or use another package to replace urllib3.

1 Like

I don’t see any indication that urllib3 doesn’t already support OpenSSL 3.x, only that OP’s system doesn’t have it.

2 Likes

You mean that if only the OP’s system had at least OpenSSL 1.1.1+ then urllib3 would be happy?

@Cliff are you on a old LTS system?

2 Likes

Yes. Many thanks!