"Internal Server Error" when trying to sign the CLA

I went through[1] the new CLA signing flow this morning (British time) for my GH username+ID email, but it failed with a hard HTTP 500 Internal Server Error after the OAuth application approval stage.

I’ve since tried on two independent devices and via a variety of different internet connections, and through two autogenerated signing links on PRs, all of which lead to the same end state.

Is this a known problem at the moment? It is rather hard to know how to reset the status – going to https://cpython-clabot.herokuapp.com/ doesn’t provide an obvious button to sign, and there isn’t any information returned by the app in the HTTP headers, or a link to a status page on the CLA site to check if things are down.

Response headers
HTTP/1.1 500 Internal Server Error
Server: Cowboy
Connection: keep-alive
Date: Sat, 07 May 2022 17:17:23 GMT
Transfer-Encoding: chunked
Via: 1.1 vegur

Basically I am a bit stuck – I’d appreciate any advice!

A


  1. python/peps PR: Refactor `peps.json` logic into PEP class by AA-Turner · Pull Request #2585 · python/peps · GitHub ↩︎

The authorities have been informed.

2 Likes

Based on this comment the bot shouldn’t be asking you to sign the CLA for the GitHub noreply email if you’ve signed previously (which I’m sure you have, you’ve been here a while). The CLA site might be erroring because it’s encountering the noreply address.

I am by no means a TypeScript expert, but looking at the code here it seems to be trying to match the username from the noreply email (aa-turner, all lowercase), to your username (AA-Turner). The case differs so presumably it’s not treating it as a match.

2 Likes

Thanks both!

@domdfcoding would the case mismatch issue also cause the HTTP 500 code? I don’t know where the function you linked fits in to the bot’s workflow. (No worries if you’ve no idea either!)

A

Everyone, I’m looking into this but I’m being slowed down by a power outage in my area Now that everybody switched to LTE for Internet, it slowed down to a crawl and there’s little I can do to interact with bots deployed in the US.

You’ll likely have to give me some time until tomorrow or so to resolve this. Thanks for your patience!

2 Likes

No rush at all Łukasz - thank you very much for looking in to the problem!

(And I hope your power comes back on sharpish)

A

Would it be possible to have an update on this please?

No worries if you’ve no definitive time scales, but as someone bumped the CLA check to ‘required’ where it previously wasn’t (at least on the PEPs repo), I can’t do anything with my own PRs, although I can still merge others’ — a pretty odd predicament to be in!

A