Is there a recent Mac install issue?

I’ve filed Installation on macOS fails with "The installer encountered an error" · Issue #103207 · python/cpython · GitHub to keep track of this (although I currently don’t know if we can do anything about this other than documenting the issue).

Can an issue be raised with Apple?

Anyone can use feedback assistant to file an issue with Apple :wink:

Same here but I did see that Privacy and Security section Files & Folder show Installer has access to both Downloads Folder and Desktop Folder.

I turned off access to Downloads Folder, download 3.12a6 into ~/Downloads and it installed ok.

I’m very curious about what config is blocking this, cannot repro myself.

Of late, about 1 in 20 of my students is also getting an installation failure. Since it doesn’t happen to everyone, but does happen repeatably, it must be something unique about their settings.

We hypothesized that it might have something to do with an install source or target like OneDrive or Dropbox.

Does Installer have “Full Disk Access” privileges? On my system Installer does not and turning off “Download Folder” is enough to trigger the error with a freshly downloaded installer.

Could someone using these products test this for the install source? The target hopefully is local because our packages install into a system wide location and not a user home directory.

Also for anyone running into this:

  • Where is the installer package located when starting the installation (Downloads folder, Desktop folder, Dropbox, …)?
  • When the installer package is on the Desktop or a Documents folder: is that directory stored in iCloud (System Settings → iCloud → iCloud Drive → Desktop & Documents Folders)?
  • What version of the OS do you use?
  • What are the settings in “Privacy & Security” → “Full Disk Access” and “Files and Folders” for the “Installer” application?
  • In “Privacy & Security”: Is “Allow applications downloaded from” set to “App Store” or “App Store and identified developers”?

BTW. I filed a report in Feedback Assistant for this using the way I can reproduce the issue.


Full disk access is disabled for Installer on my mac.

Also I do have Dropbox installed, but it is not allowed to sync Downloads.

First, yes I used Terminal and no other program on the mac. On the website I downloaded the big yellow button on the home page that says "Download the latest version for MacOS. The yellow button says [ Download Python 3.11.2]. I also tried earlier versions and the same install failure happened. Just in case the new mac M2 came corrupted I reloaded the operating system and still had the same failure in the middle of the download process. It lets you go half way through the process then cops out. I’m not sure how you can confirm what was downloaded matches the MD5 listed on the Python website if you can’t open it or go through the whole install process. The only way I know is to go to the Terminal and type ‘md5’ and drop the download package onto the terminal but that didn’t work either. In terminal when I do this I get a “no such file or directory: md5/Users/…”.etc, etc. response from terminal. I’ll call apple tech and see what they say. I needed python because I use an older version of a 3d slicer called Cura that will not run on the new M2 apparently without installing Python. Very unpleasant and not user friendly.

Was having the same problem. Just now found the problem!!! As you click through the install when you get to the “Installation Type”, rather than just keep clicking on the default “Install”, I clicked on “Customize”. At the top, the option for Python Framework" Upgrade was checked by default. I checked that box at the top. It says it will install the framework that is python interpreter and the standard library. It is 102.7 MB. Then I clicked install and it finally worked!!!

FIXED and found the problem – not sure why but… When you are clicking through the download options, rather than just keep selecting install, at this juncture you have to select the CUSTOM button to the left and check to install the top choice of install Python framework. Maybe because the new Macs do not have it all by default though I think there is some version - not sure? Problem solved and thanks.

The issue here is that spaces are needed to separate parts of a command line.
So you can type md5, then space, then the path to the file (by typing or using drag-n-drop as you did).

1 Like

Excellent, worked. I must not have put a space. Appreciated

See the update at Installation on macOS fails with "The installer encountered an error" · Issue #103207 · python/cpython · GitHub

UPDATE: it appears that Apple has fixed this problem in the macOS 13.4 update for Ventura. The macOS now asks for permission to access special folders, like Downloads, even if you have denied access on a previous install attempt.


Hi there, this problem has been happening to me on mac and I had tried all of the fixes I could find (unsuccessfully) before realising that the missing step is dragging the downloaded package to the applications folder - then it works! Just sharing in case anyone else finds this helpful :slight_smile:

Thank you so much Omar as well! This has worked for me.