Issue with attribute "isAlive" [SOLVED]

Hi Everyone!

I have updated my python from 3.7 to 3.9. I am using Pyzo and Anaconda on Windows.

The issue is that I cannot use my shell in pyzo, because the shell is not initializing. I have an issue : AttributeError: ‘ThreadForReqChannel’ object has no attribute ‘isAlive’

The kernel is killed before being ready.

I have seen that this problem is common with python version after 3.8. In a code, isAlive was changed to is_alive. But I do not know how to repair my python. In fact, I do not have the rights to modify the pyzo files. I also cannot run a command on my pyzo, I do not have a shell.

Thank you for your assistance

Please be more specific. If you report a problem or error, post the exact actions that you performed and then the whole stack trace - the final error by itself is usually not informative. Also, simply saying “I updated my python” can mean lots of different things, so it’s not at all clear how you got into that problem.

It then also helps if you confirm whether or not an app like pyzo supports the Python version you are using.
If you already have more information, then it also helps to more precise. For instance “in a code isAlive was changed” raises the question - in which file was this changed?

In this case - the error message happens to give just enough info. In Python 3.9:

The isAlive() method of threading.Thread has been removed. It was deprecated since Python 3.8. Use is_alive() 

The fix for you is probably to uninstall your current pyzo - since I suspect you are trying to use the old package inside a new Python environment. Then inside your new Python 3.9 environment reinstall pyzo from the Pypi.


Thank you for the information.
I started with a python in 3.7. I wanted to update python and anaconda.
I did :
conda update anaconda = 2022.10 python = 3.9
I also updated conda after it :
Conda update --all
But when I reboot and try to use pyzo, the shell issue happens .

How can I reinstall pyzo without a shell? I did not understand the instructions you suggested me.


I successfully desinstalled the old pyzo, and installed the most recent pyzo.

My problem is corrected : the shell is operational with a python above 3.8.

So to update my python setup, I have to update python, anaconda and pyzo.

Thank you for the assistance

How do I close the discussion? Do I indicate on the tile [SOLVED]?

Nice to see that you managed to solve it :slight_smile: Yes - if you want, you could add [SOLVED] to the title.

FWIW, you might want to consider checking out Spyder, which is included with Anaconda (as well as available from pip/PyPI, Conda/Conda-Forge, WinPython, source, and standalone installers, etc). It is very similar to Pyzo in its goals, language/GUI framework, design, layout and all its basic functionality, and was even started right around the same time (2008-2009), but has many more sophisticated features, a much more refined and modern UI, and much more active developed by a much larger team and community rather than ≈one person, as well as has a growing ecosystem of first and third-party plugins to further extend its functionality (Spyder-Notebook, Spyder-Terminal, Spyder-Unittest, Spyder-Env-Manager, etc). Of course, full disclosure I’m one of the Spyder developers.