Issue with IDLE

Hello All,

I am a network manager at a secondary school and our students are currently studying python as part of their ICT Curriculum,

I seem to be having issues with IDLE holding onto previous commands and consistantly erroring out for students.

they get the above occur it seems to happen after they have created a new file and tried to run the module. majority of students have it working no problem but a few students get the above error and even after closing IDLE either from the X in the top of the window or with the exit() or quit() commands it still seems to hold onto this error as shown in the image this is happening by me simply trying to import turtle without running a module and it tried to run a module anyway.

is there any temp files or caches or even registries i can change to resolve this issue?

any help would be gladly received!

This is not an IDLE issue, but general Python thing. The students having this issue called their source file, shadowing the like named module from the standard library. Python gives the cryptic error, because it thinks they will/may be defining forward later in the module. Have the student change the name of the source to something else.

1 Like