Issues with installing Wheel

Hello,

I am working on an offline machine, and I need to update/install some Python dependencies.
I am using python-3.12.1-amd64.

I am trying to install/update wheel-0.42.0 module:

py -m pip install Dependencies/wheel-0.42.0.tar.gz

But it is failing due to lack of flit_core<4,>=3.8 being not satisfied.

When I do pip list, it is showing flit_core 3.9 being installed.

I tried install flit_core version 3.8 but I get same result, any ideas?

What if you do py -m pip list, to match the py -m pip install?

That showed exactly the same list.

But, I found that if I got wheel-0.42.0.whl instead of wheel-0.42.0.tar.gz it just worked…
Weird, but fixed :slight_smile:

The .tar.gz is source code of the wheel.
The actual wheel is the .whl file.

I realize that you’ve solved your problem, but for the future or if you’re still interested in understanding the issue, please include the full error message.

pip uses build isolation to build wheels. That means it won’t use the flit-core that you have installed, it will create a temporary environment for the build and install flit-core into that.

1 Like