So, it would seem there’s an unspoken rule about methods that would, strictly, have underscores in them but don’t. There’s nothing in PEP8 about this.
I’m guessing the thought process is that it’s okay as long as the name is still understandable. But, what’s wrong with
remove_prefix? Is saving those one or two extra characters really worth it?
It’d be nice if the core maintainers could chime in what they consider acceptable for dropping the underscore (not that I mean to bikeshed).