ModuleNotFoundError: No module named 'modName'

I have seen several discussions on this, tried several solutions to no avail.
I’ll use the ModuleNotFoundError: No module named ‘KalturaApiClient’ as example, given this is my actual issue but I have encountered this with other modules.
I have installed the module in two different paths with pip:

pip install KalturaApiClient
pip install --target="C:\Program Files\Python312\site-packages" KalturaApiClient --upgrade

Also I checked that the paths are available:

print(sys.path)
['', 'C:\\Program Files\\Python312\\Lib\\idlelib', 'C:\\Program Files\\Python312\\python312.zip', 'C:\\Program Files\\Python312\\DLLs', 'C:\\Program Files\\Python312\\Lib', 'C:\\Program Files\\Python312', 'C:\\Users\\myUser\\AppData\\Roaming\\Python\\Python312\\site-packages', 'C:\\Program Files\\Python312\\Lib\\site-packages']

Even after this was done, the issue prevailed so I went into the folders to check that it actually exist. Those files are within the provided paths!
Later I check that I was not working inside a virtual environment, this was not the case.

I feel I’m missing something, what could it be?

Its not included in the sys.path. Double check this. The ones that you do have that are similar:

1. 'C:\\Users\\myUser\\AppData\\Roaming\\Python\\Python312\\site-packages', 
2. 'C:\\Program Files\\Python312\\Lib\\site-packages']
1 Like

Thanks! I feel kinda silly but after all I was really missing it. :rofl:

1 Like

Why are you using the --target option? The defaults should have “just worked” on Window.

2 Likes