Need help with installation

On my windows 11, I have been trying to install python 3.10.6 and searching everywhere on my computer where this could be for the past 5 hours but everytime I try to install python it says “A newer version of python 3.10 is already installed” no matter what I uninstall that is python related. How can I fix this error please I tried every websites solution and everything I could think of I don’t know what to do anymore im tired and I need help with this because my app keep asking me to use 3.10.6

Try typing where python in a Command Prompt window. That should tell you the location of every version of Python it knows about.

It only shows me the 3.11.4 one that I also installed and one in


that I can’t uninstall or do anything with

More information is needed to understand the context for the problem.

Exactly what steps do you take in order to try to do this?

What is “it”? Exactly what do you see?

If the computer thinks that this Python is installed, why do you think you need to install 3.10.6? What problem happens right now because you haven’t installed it yet? Why do you think that problem will be solved, if you get the installer to work?

I agree I did not specify enough and I’m sorry for this!

The steps is I download the 64-bit version from Python 3.10.6

For what I see it is that

I tried something this morning that broke an app that worked on that version. Tried to reinstall it and now it just doesn,t work anymore. Yes I know that wasnt very smart of me.

What is the “something” that you tried? What app broke? Which version (do you mean a version of the app, or a version of Python)? What do you mean by “doesn’t work” - what are you trying to do; what is supposed to happen; and what happens instead?

I think the version of the app again Im not the best in wording things so I’m sorry for that. The app I was trying to use is Stable Diffusion. If I recall the something I did was uninstalling python to reinstall it in another location but I don’t know if I uninstalled it the right way(I obviously don’t think so because it says its still here so there must be hidden files of it somewhere) and now I get the error

“ERROR: Could not find a version that satisfies the requirement torch==2.0.1 (from versions: none) ERROR: No matching distribution found for torch==2.0.1”
which did not happen before I tried to move python. From what I understand with my change it only works(is supported) on python 3.10

This is why I’m trying to reinstall Python 3.10.6 because it worked perfectly before but It keeps saying this.

Have you looked in the windows settings programs section?
It will list all the installed software and allow you to uninstall programs you do not need.

We used these instructions to install easy stable diffusion Installation | Stable Diffusion UI v2
It worked first time for my Son.

1 Like

Check for an existing installation of 3.10 in the following registry keys:

  • HKCU\Software\Python\PythonCore\3.10\InstallPath
  • HKCU\Software\Python\PythonCore\3.10-32\InstallPath
  • HKLM\Software\Python\PythonCore\3.10\InstallPath
  • HKLM\Software\WOW6432Node\Python\PythonCore\3.10-32\InstallPath

Try installing 3.10.11 (x64 installer). If there’s an older version of 3.10 installed, it should upgrade it in place.

1 Like

Apparently I still had some stuff in there. Thanks it works now!!

I don’t understand what that has to do with the error you show, nor can I really understand anything about your thought process up to this point with the problem. If you had 3.10 before, then why would uninstalling and reinstalling fix a “3.10 is required” problem? Aside from that, all the documentation I can find suggests that 3.8 onward should work.

What is “it”? What do you mean that it “keeps saying” that? When does “it” say that (specifically what action do you, as a user of the computer, take, in order to cause “it” to say that)?

Same problem…can’t install 3.10…i tried to install a new program and it wanted to install python…so I stoped it …canceld it …went to use my stable deffusion…now I get Python path configuration:
PYTHONHOME = (not set)
PYTHONPATH = (not set)
program name = ‘python’
isolated = 0
environment = 1
user site = 1
import site = 1
sys._base_executable = ‘C:\Users\paul1\AppData\Local\Programs\Python\Python310\python.exe’
sys.base_prefix = ‘’
sys.base_exec_prefix = ‘’
sys.platlibdir = ‘lib’
sys.executable = ‘C:\Users\paul1\AppData\Local\Programs\Python\Python310\python.exe’
sys.prefix = ‘’
sys.exec_prefix = ‘’
sys.path = [
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
Python runtime state: core initialized
ModuleNotFoundError: No module named ‘encodings’

Current thread 0x00003fac (most recent call first):

Fixed it…undid restore…found some files in recycle bin restored then and done a reinstall on 3.10 …and this time it installef …boom all working again … thank god for that …thought I was looking at a complete reboot…all my stable deffusions are now back working…only took 3 hours …