Pip is not working fine on python 3.9 and newer

So, i’m a linux user and my default version for python is 3.6.5
And then i installed the python3.10 but when i tried to install pip3 it was installing pip2 and when i tried to install pip by using get-pip.py it was giving me this error
So i can’t understand why there is no an update for get-pip.py for python3.9 and python3.10
And i can’t use pip3 any where cause it’s not working!