As proposed by @aeros on the python-dev mailing list, “Core Development” is probably a better descriptor of the category so it doesn’t get confused with “Core Developer”
For additional context, see the python-dev thread.
Done. If people end up getting confused we can change it back. I did keep the short name, though, so it’s still #core-dev for the shorthand.