SOLVED: module PyQt6 not found

I would like to share this with you,
especially for newbies, like me yeah: slight_smile:

This was the case:
I am totally new with python, so I began editing code from
internet and later, I bought a book, for programming a GUI
(Grafic user interface)

Every time after coding “import PyQt6 from blah blah”,
again and again I got the error module PyQt6 not found!

-Note that the python IDLE gave no error after import PyQt6,
witch means that the import was succeeded.

-Running code in the mu (simple python editor) gave time after time the error
-After installing pyCharm, and running the code: same result.

On internet forum you see: uninstall and install PyQT6,
or goto pyton dir and type install PyQt6, or pip install PyQt6.

Nothing worked

The solution was typing the code in pycharm.
The coding with warnings and/or problems are underlined.
IF you hover the mouse over it, it will suggest a solution for the problem.
In this case download a interperter PyQt6 (or something like that)

Then …taraaaaaa solved!!!

User-installed modules are usually found in the lib/python{version}/site-packages directory of your Python install or virtual env (that’s where pip or conda put them). To see which packages are installed:

pip list  # or: conda list  (if you're using conda)

It’s seems strange that pip install PyQt6 didn’t work for you. What exactly did you do to solve the problem?

I left the mu editor behind, installed pycharm, and followed the suggestion on
pycharm.
Pycharm did grab the nessesary files and the problem was solved.

The mu editor does not have this possibility, so with the mu-editor this problem
will never go away.