Stabeldiff no work anymore: no module named pip

Its been a while since i launched stable-diff and normally it works fine but today i get this

exit code: 1                                                                                                                                                                                                                                    stderr:                                                                                                                 C:\msys64\ucrt64\bin\python.exe: No module named pip                                                                                                                                                                                            Launch unsuccessful. Exiting.                                                                                           Press any key to continue . . . 

so far ive tried

  • uninstall and install python 3.10.6
  • "\stable-diffusion-webui\venv\Scripts\python.exe" -m ensurepip --default-pip --upgrade --verbose
  • python3 -m ensurepip
  • deleting venv folder

Where did you get python from?
Of you just want ro run stable diffusion have you tried the easy installer?
I think this is the link https://easydiffusion.github.io/

in case anyone else has this problem, open cmd, change directory to the stable-diffusion-webui folder, and doing python -m ensurepip worked for me

But that is never needed for python.org python.
So not useful infomation without knowing where got your python from.