Troubleshoot download issue with Python 3.10

Issues downloading Python 3.10 on my Mac!
When I run python --version, terminal tells me Python 3.9.5
I have downloaded Python 3.10.2 via, and installed, but still when I run in the terminal, I’m on Python 3.9.5. Any ideas?

(base) mary@iMac ~ % python --version
Python 3.9.5
(base) mary@iMac ~ % where python
(base) mary@iMac ~ % 
1 Like

You are running the python that ships with macOS.
The one you installed is in /usr/local/bin.
Make sure to add that to user PATH in your ~/.zprofile which the python installer usually does for you.

Did you start a new terminal after installing python? Maybe you are not running with the updated PATH?

Looks like she’s running the python version that ships with miniconda.

You would have an easier time installing a newer version of Python via miniconda since you already have it. Are you against that option?

1 Like

I believe I did install with minicomda - I ran Anaconda-clear, which wiped the .conda files out, but it’s still showing in this path to Python.

I would prefer to not use miniconda anymore - how would I “deactivate” this miniconda?

In the past on Linux, I believe I simply deleted the miniconda folder. (Maybe move /opt/miniconda3/ somewhere else first to be safe and see how it runs after a reboot).

And one more thing …

Your % where python command suggests miniconda was prepended to your PATH. To clean that up, you’d have to search where miniconda added itself to your PATH and comment it out, e.g. whatever ~/.bashrc-equivalent file is on Mac (maybe ~/.zprofile?)

Also …

Backup. :slight_smile: Installing Python from on Mac/Linux can be tricky sometimes. GL.

1 Like

Its .zprofile on macos and .bash_profile if using bash not, unless you want problems, in .bashrc


Thanks everyone for the responses. Getting rid of Anaconda was a frustrating experience.

As @pylang and @barry-scott indicated, I needed to update the terminal profile.

After running the full uninstall, I updated the terminal profile:

open ~/.zshrc

Deleted the contents and miniconda3 is here no more - wahoo!

1 Like