Unable to update pip properly

I tried to update pip without activating my conda environment and it worked, but then as soon as I activated my environment the pip version came back to its original

Here is the same in text format

(C:\Users\Siddharth Singi\Miniconda3) C:\Users\Siddharth Singi>python -m pip install --upgrade pip
Requirement already up-to-date: pip in c:\users\siddharth singi\miniconda3\lib\site-packages (19.2.3)

(C:\Users\Siddharth Singi\Miniconda3) C:\Users\Siddharth Singi>activate RL

(RL) C:\Users\Siddharth Singi>pip --version
pip 19.0.2 from C:\Users\Siddharth Singi\AppData\Roaming\Python\Python36\site-packages\pip (python 3.6)

(RL) C:\Users\Siddharth Singi>

Can someone please explain to me how is pip being updated in one place and not the other, please answer in as much detail as possible

FYI I don’t know if many members of the conda community are here, so you may not get an answer here. I would advise asking where conda prefers having questions asked to get an answer.

Thanks for the heads up I have posted it here:

@brettcannon Is there any better discussions forum for anaconda that you may be aware of?

I’m not part of the conda world so I unfortunately don’t know.