I agree with Brett.
It’s a pity that we didn’t name the method assertCountsEqual (note the
use of plural counts). The singular name suggests:
- a count (which one?) is equal
while the plural suggests:
which is the actual behaviour.
Perhaps we could rename the method to the plural, and immediately add an
alias with the former name and depreciate the alias. That is:
the preferred spelling becomes assertCountsEqual;
old spelling remains for backwards combatibility, but deprecated.
Is it worth is? shrug I don’t know. If this was a spelling error in
the documentation, I would say “just fix it” but (alleged) spelling
errors in APIs are a different story.