Using Travis CI GitHub App (instead of service)


#1

Today’s the day where GitHub finally deprecated “services” in favor of GitHub Apps.

Seems like we’re still using travis CI ‘service’ instead of the GitHub App.
There’s a write up here, where an admin need to configure and allow travis CI GitHub App to be installed.

https://docs.travis-ci.com/user/migrate/legacy-services-to-github-apps-migration-guide/

Perhaps we need to start doing this before end of the day today?


#2

cc @EWDurbin


(Ernest W. Durbin III) #3

I’ve updated the settings for the GitHub App for Travis CI (travis-ci.com) to have access to all repositories on the Python Organization.


(Ernest W. Durbin III) #4

I’m not sure what to do from here unfortunately. The documentation notes an “Activate and Migrate” button that doesn’t seem to exist. I’ll email Travis CI support and CC you @Mariatta


#5

Thanks!!

The other “service” we have is IRC but I don’t know anything whether they have GitHub App or not.


#6

Seems like it’s been “installed” in CPython…


#7

@EWDurbin are you able to configure things from https://travis-ci.com/organizations/python/repositories?

For me, the repos are disabled:

I tried making a PR in devguide, but it doesn’t seem to be building using the GitHub App.


(Nathaniel J. Smith) #8

Travis’s messaging about this has been really bad. I guess being acquired last week probably doesn’t help. They finally posted a new update today.

The original plan they announced is to move everyone from .org → .com, but the tool for that is still in “private beta”. There’s an email address you can contact to get into the beta, but it looks like they just didn’t get this together in time.

Instead, a few weeks ago they started going through all the repos that were using the “service”, and using their credentials to also configure a “webhook”. If you go to https://github.com/python/cpython/settings/hooks and see an entry for notify.travis.org, then I think that means that the repo has been migrated and everything should keep working. (And presumably at some point in the future there will be another migration, to get to travis-ci.com and our glorious App-alicious future.)


(Ernest W. Durbin III) #9

@njs Thank you for that context!

@Mariatta I am able to configure things in that UI, but not for anything on the Travis-CI.org :confused:

I’m gonna try the gem they wrote to enable the web hook for everything.


(Nathaniel J. Smith) #10

Their latest announcement says that most projects don’t need to do anything at all:

For the majority of your repositories, this transition has gone smoothly without any issues. On your end, you will not need to take any action and you’re good to go as if nothing changed! – https://blog.travis-ci.com/2019-01-31-github-services-integration-deprecation


(Ernest W. Durbin III) #11

Hmmm, then I’m curious why devguide PR didn’t do anything.


(Ernest W. Durbin III) #12

Oh, @Mariatta it looks like your PR did end up getting Travis’d


(Ernest W. Durbin III) #13

heh… no joke. this is wild. wish them the best moving forward. once again thank you @njs


#14

Yeah but the “details” link to travis-ci.org instead of .com


(Ernest W. Durbin III) #15

@Mariatta it appears that the org => com thing just isn’t happening at this point. If we’re getting builds, I think we should just hang tight and await what Travis does on that front next.


#16

In devguide, I saw the webhook https://notify.travis-ci.org/
I tried changing that to .com, but it didn’t do anything (no build happened)

I’ve changed it back to .org.

:woman_shrugging:t2:


(Guido van Rossum) #17

I wonder if this is also why a few weeks ago it appeared that several readthedocs projects stopped being updated? I had to fix this for mypy, and IIUC Benjamin had to fix this for six; I vaguely recall another.


(Ammar Askar) #18

Yeah it is, I got an email from readthedocs about it though that linked here: https://docs.readthedocs.io/en/latest/webhooks.html#webhook-github-services


#19

Ok I think I understand this now…
Indeed they’re not using GitHub “service” anymore, but travis has added the webhook to our repos. Builds are still happening, via webhooks to travis-ci,org.

At this point, perhaps nothing we need to do here, other than removing the travis-ci service from our GitHub repos? (check first that the webhook exists).