'virtualenv' command does not work (windows 10)

Hello! I want to create a virtual environment, in order to do a tutorial series on python.

The ‘pip’ and ‘virtualenv’ are installed.

When I run: virtualenv Project1_env
I get the following error:
FileNotFoundError: [Errno 2] No such file or directory: ‘d:\anaconda\anaconda3\Lib\venv\scripts\nt\python.exe’

What should I do to get rid of this error and create the virtual environment?

Pretty sure this is your problem. I found the solution on stackoverflow.

This stackoverflow discussion is about venv command, not about virtualenv.

Actually, I solved this problem, by using a little bit modified solution from this ‘stakoverflow’ discussion.

This is the original solution:

I copied following files from python location( C:\Program Files\Python37 ) to the ( C:\Program Files\Python37\Lib\venv\scripts\nt ) and it worked for me

1) python_d.exe
2) python_d.pdb
3) pythonw_d.exe
4) pythonw_d.pdb

I did the same thing with these files, but in my anaconda location.

Thanks for the hint!