Cannot make the new release to be the latest version for installation

Hi all,

Previously, when I made a new release, the newly released one will be the latest version for the users to install. However, today, I tried several times for making a new release. The latest version is always the old one.

The “latest version” which is old one (1.1.0): ANNOgesic · PyPI

I do have the newly released ones: ANNOgesic · PyPI It also show that this one is the latest version…

But when I tried to install it, the installed package is 1.1.0 which is the old one. If I typed pip3 install ANNOgesic==1.1.4 it will show

ERROR: Could not find a version that satisfies the requirement ANNOgesic==1.1.4

ERROR: No matching distribution found for ANNOgesic==1.1.4

The command that I used for uploading my code is the following

python3 sdist bdist_wheel

twine upload dist/*

the content of is:

from os import path
from setuptools import setup
except ImportError:
from distutils.core import setup

here = path.abspath(path.dirname(file))

with open(path.join(here, ‘README.rst’)) as f:
long_description =

author=‘Sung-Huan Yu’,
description=‘ANNOgesic - A tool for bacterial/archaeal RNA-Seq based genome annotations’,
“biopython >= 1.65”,
“matplotlib >= 1.5.0”,
“numpy >= 1.9.2”,
“networkx >= 1.9.1”
license=‘ISC License (ISCL)’,
‘License :: OSI Approved :: ISC License (ISCL)’,
‘Operating System :: POSIX’,
‘Programming Language :: Python :: 3’,
‘Topic :: Scientific/Engineering :: Bio-Informatics’,

I do not know what happens… How can I make the new release to be the latest version and the user can install the newly released one by using pip3 install?



until the second paragraph I did not have idea that the post is about PyPI. I think the topic would be more accessible if PyPI is mentioned in the subject.

There is this few hours old post describing the same problem (I think):

Is not there a problem on the PyPI server?

True, my issue should be the same as that one. I think what I can do is the same as that one - wait until it starts to work… Thank you anyway.

There’s been a flurry of related activity in
Packages randomly missing from simple index · Issue #10390 · pypa/warehouse · GitHub over the past day as

I have exactly the same issue with my project django-odk
twine works and version 1.1.3 is uploaded but when I try pip install django-odk==1.1.3 I get

Error text:
ERROR: Could not find a version that satisfies the requirement django-odk==1.1.3 (from versions: 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.1.8, 0.1.9, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4, 0.2.5, 0.2.6, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 1.0.0, 1.0.1, 1.0.2, 1.0.3)
ERROR: No matching distribution found for django-odk==1.1.3

You can probably monitor the status of PyPI via:

After around 5h, the issue was solved. I guess the PyPI server was under maintenance at that moment.

This was due to Python Infrastructure Status - Queue delay affecting CDN purges and emails