Py.exe not working after 3.11rc1 install

I have a Windows 10 VM that I use to build extensions for python.

Previously I had 3.11a3 installed.

After installing both python 3.11rc1 32 and 64 bit versions the py command is not working. Here is what I see in cmd:

: 10:12:15.43 C:\Users\barry
: \\VM-WIN10\barry> py
No suitable Python runtime found
Pass --list (-0) to see all detected environments on your machine

: 10:12:18.43 C:\Users\barry
: \\VM-WIN10\barry> py -0
 -V:3.11          Python 3.11 (64-bit)
 -V:3.11-32       Python 3.11 (32-bit)
 -V:3.10          Python 3.10 (64-bit)
 -V:3.10-32       Python 3.10 (32-bit)
 -V:3.9           Python 3.9 (64-bit)
 -V:3.9-32        Python 3.9 (32-bit)
 -V:3.8           Python 3.8 (64-bit)
 -V:3.8-32        Python 3.8 (32-bit)
 -V:3.7           Python 3.7 (64-bit)
 -V:3.7-32        Python 3.7 (32-bit)
 -V:3.6           Python 3.6 (64-bit)
 -V:3.6-32        Python 3.6 (32-bit)
: 10:13:49.37 C:\Users\barry
: \\VM-WIN10\barry> type C:\Users\barry\AppData\Local\py.ini

Did I do something wrong?
Is this a bug?
Do you want a bug report?


Very definitely raise a bug report. And flag it for the RM’s attention, as it has the potential to be a release blocker, even at this late stage. I hit a couple of bugs in the new py.exe implementation earlier in the release cycle, but it’s been fine since rc1, so it’s possible you’re hitting an edge case - but better to get it reported so someone can check.


I ran into this too, it looks like the -64 has been dropped from name of the 64-bit versions now for the launcher (see the listing). Just make that change in your py.ini: python=3.10 and it should unstick it. Whether this was an intentional change, I couldn’t easily determine.

How do I flag it for RM attention?

1 Like

I’ve commented on the issue and pinged @pablogsal. I’ve also marked it as a release blocker pending his decision.

1 Like