Windows thinks I have a "newer installation of python" and wont let me install python

Im running windows 10 professional OS

I am a complete newb with this stuff so please keep that in mind when answering, I do not know any lingo, do not assume i understand anything!

I was using python to run stable diffusion from my machine and wanted to try cascade, I had an error trying to use cascade which I was told was caused by a faukty install of python, and that I could fix it by uninstalling all of the versions of python I had and reinstalling python 3.10.6 (I guess I need this specific version to run cascade and or automatic1111)

anyway, i had what looked like 3 installations of python, 2 of the 3 seemed to uninstall without issue, but the third did not…
Eventually after googling solutions i tried revo uninstall which did remove python from my “add remove apps” list
but I am unable to install Python 3.10.6 because when I try i get an error saying i have a newer installation of this already…

nothing works now, not cascade or automatic1111

I removed python.exe and python3.exe in cmd (another solution google offered up) from appdata/microsoftapps - still nothing

Yes I have tried restarting.

Please help!

It is supported to have multiple versions of python installed on windows.
Maybe the issue was that python 3.10 was not the version on the PATH?

When you look in the windows setting “add remove programs” do you see python 3.10 listed?

Did you always use the windows setting “add remove programs” uninstall options?

You say google pointed you to commands to delete files.
That advice sounds unwise.

Do you have the py.exe command still installed?
In a CMD terminal what does py -0 output?

Finally there is a stable diffusion easy install program that does all the hard work for you. I used that to bet my Son set up with stable diffusion a while ago.


stablediffusion was working wonderfully for me, it only stopped working when i uninstalled python (obv lol)

Python is NOT listed in add remove programs (after i tried uninstalling with revo)

the google result sent me to a discussion on stack exchange where someone else couldn’t remove their python and one of the suggestions was to open a cmd window and remove python.exe…

I looked before doing that in the path they gave, and there was in fact a folder with python.exe and python3.exe inside of it
and shouldnt have been… since i had already “uninstalled” everything

so i doubt that gunked anything up worse than it already was

im unclear how to determine if i have py.exe command installed,

I typed
py -0
in a cmd window and it says C:\Users\red>py -0
‘py’ is not recognized as an internal or external command,
operable program or batch file.

the really dumb thing i did was when i deleted cache files the other day, I wanted more space on my c drive and deleted anything that said cache basically… including “package cache” - i believe this was the beginning of the end for me.

when i was first trying to uninstall python it said i couldn’t because it couldn’t find the package cache associated with it.

did i break everything forever? :frowning:

I do not know if that package cache was important or not.

No problem withe the py.exe, it should have gone when the last python was uninstalled. It will return once you have at least 1 python version installed.

You may find that there are setting in the windows registry that have not been cleaned up that are causing the problem. Cleaning up the registry is an advanced, and dangerous, task.

Are you still in the situation that python 3.10 will not install?
Suggest you try python 3.10.11 kit from Python Release Python 3.10.11 |
Does that install work?

yes i strongly suspect this is a registry thing, but like you said, its dangerous so i havent touched that.

it did install, (as did 3.11) but didnt make stable diffusion start working again, will I need to do all of that from scratch again?

it said venv “D:\AI\stable-diffusion-webui\venv\Scripts\Python.exe”
No Python at ‘C:\Users\red\miniconda3\python.exe’
Press any key to continue . . .

in the cmd box when i tried to open it… (which is better than what it was saying before i suppose)

Miniconda is another way to install python that is different to versions. Did you install conda or miniconda?

I expect you need to rebuild that venv.

1 Like

i appreciate your help so much ty

when you say rebuild that venv what does that mean?

I mean this venv. How was it made?

oh, I followed instructions on a youtube channel, I can do that again from, scratch, I have all my saved models so it shouldnt be a big deal

Suggest you keep notes on what steps you do so that you can share if things go wrong.